App sync issues
Incident Report for JourneyApps
Postmortem

We had an issue today where apps were unable to sync new changes from our backend servers for around 90 minutes

. During this period, some apps displayed sync errors, or continuously tried to sync, without getting the latest changes.

The issue was caused by an update in the sync processing code on our backends. The update optimizes some aspects of sync reprocessing, which should ultimately result in improved sync performance. Unfortunately, a bug in this update caused a small number of apps to immediate trigger sync reprocessing.

Even though it was a small percentage of apps performing reprocessing, it was enough to saturate the sync processing queue in our ZA backend. This caused sync processing for other apps to be delayed, which prevented users from those apps from syncing the latest changes.

We resolved the issue by scaling up the sync processing capacity, and cancelling reprocessing for apps where it was not required.

To avoid this issue from occurring in the future, we are making changes to the sync processing system to ensure that reprocessing is never prioritized over processing the latest changes. This would ensure that even when a large number of apps are busy reprocessing sync rules, the latest changes would continue to be synced in all apps.

Posted Jun 28, 2022 - 06:38 MDT

Resolved
This incident has been resolved.
Posted Jun 28, 2022 - 03:53 MDT
Update
ZA backend is fully recovered.
US backend may still have some minor performance issues.
Posted Jun 28, 2022 - 03:39 MDT
Monitoring
An issue on the backend caused app sync to fail or continuously retry since 07:40 UTC.

We have fixed the underlying issue. The systems are recovering, but may still have some performance issues until fully recovered.
Posted Jun 28, 2022 - 03:11 MDT
This incident affected: Regional Cloud Backends (Backend - AU, Backend - EU, Backend - ZA, Backend - US).